MACD指标:MACD四种形态的选股公式【通达信】

本文有326个文字,大小约为1KB,预计阅读时间1分钟

 

  4种利用MACD选股公式分别是:二次金叉,二次翻红,DIF下破0轴及0轴附近金叉。一起来看看

  (1)二次金叉:

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=2*(DIFF-DEA);

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

  二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

  (2)二次翻红:

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=2*(DIFF-DEA);

  FH1:=REF(MACD,1)

  FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

  FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);

  FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;

  FH5:=FH1 AND FH2 AND MACD<0.10;

  FH3 OR FH4 OR FH5;

  (3)DIF下破0轴:

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=2*(DIFF-DEA);

  均线向上:=EMA(C,144)>=REF(EMA(C,144),1) AND EMA(C,233)>=REF(EMA(C,233),1);

  破0轴:均线向上 AND REF(DIFF,1)>0 AND DIFF<0;

  (4)0轴附近金叉(特别是0轴之上):

  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIF,9),LINETHICK1;

  CROSS(DIF,DEA) AND DEA>-0.05;

 

 

本文标题:MACD指标:MACD四种形态的选股公式【通达信】
文章链接:http://gamblers-recovery.org/gprm/rm_973.html

更多相关推荐

正规股票配资交易所推荐:上海证券交易所 深圳证券交易所 香港证券交易所

小编提醒:请远离场外配资,谨防上当受骗。选择正规理财途径确保资金安全,避免吃亏上当!

声明本站分享的文章旨在促进信息交流,不以盈利为目的,本文观点与本站立场无关,不承担任何责任。如有伤害到您的利益,请联系站长删除!

您可能还会对下面的文章感兴趣: